Do I have to pay for a Secure Certificate?

No, but you may want to still buy a secure certificate even if there are free ones available. The ability to offer free secure certficates has been established as a fact for cPanel servers. And I just turned it on for my clients – for  use on their static or wordpress websites. These cPanel-generated certificates do show the correct browser security of most users and are backed by GlobalSign. Now that the browsers are starting to note who doesn't have a secure certificate no… Read more

Should I Upgrade my Zen Cart Store?

Note: 1.5.5f was recently released. I've been led to believe it's the last update for 1.5.5. Based on that premise, I have started upgrading to 1.5.5f. More on that here. A recent patch released for Zen Cart this week had more to do with Master Card changes than Zen Cart problems. Just another thing one has to keep up with in this every changing ecommerce world. What was the shocker and, yes, I call it a shocker was the recommendation on the Zen Cart forum post in the… Read more

Zen Cart Changes for Mastercard

If you are using anything besides 1.5.5e or 1.5.5f, you may need to grab that file for MasterCard. Mastercard is starting to use card numbers that start with a two instead of a five. The 1.5.5e file that validates Master Card numbers correctly can simply be used instead for 1.5.4. That file is includes/classes/cc_validation.php. If you are using an earlier version of Zen Cart (1.5.3 and below), you may need to do some file integration but I recommend upgrading to at least 1.5.4… Read more

Zen Cart Delia Cleanup and New Additions

Finally!  I took time to make ZenCartDelia.com fully responsive. I had someone tell me last fall that it was a shame I had a website and sold responsive templates yet the site wasn't responsive. It's about that cobbler thing: so I finally got to fixing my shoes!  Along, with that I've been working updating some of pages that have left fallow for way too long.  While I was doing this, I started taking a look at some other things. I had a mod that had… Read more

Important Phpmailer Patch for all Zen Carts 1.5.1 to 1.5.5

The PhpMailer team has released a new version due to a discovered vulnerability in their code. This affects a large percentage of websites, not just Zen Cart. The fix is easy. Just upload the new files to Zen Cart – this will overwrite a number of files for the mailer but probably not files anyone has actually edited before. There should be no integration concerns.  The vulnerability would allow someone to use your zen cart installation to send emails without you knowing it… Read more